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Intended Audience This document is designed to help an entry level student install Windows 7
Professional as a virtual PC within VMware Workstation 8.0 (hereafter referred to as VMWare).
Students that are taking Principles of Information Security will likely be the biggest audience.

Introduction: Throughout your course work you will be using the Windows operating systems,
especially Windows 7 Professional. Most of the CIT Networking/Unified Communication Specialist
classes, including the core course Principles of Information Security, will require you to perform
hands-on lab activities using the Windows 7 Professional operating system within a virtual PC
environment running under VMware. This document will help you install Windows 7 Professional
in such an environment.

Prerequisites: The installation of Windows 7 Professional as a virtual PC requires that you have
VMware installed. The procedures detailed in this document also require that you have a software
serial number for Windows 7 Professional. NTC will provide you with this serial number, which has
no expiration date. These instructions will assume that you do not have this serial number, so there
will be instructions on getting it.

You are also required to have a properly formatted, external, USB hard drive.
Instructions: This is a step-by-step guide. You are advised to perform the exercises precisely as

indicated. Please read and follow the following installation steps closely.

SECTION 1: OBTAIN THE WINDOWS 7 PROFESSIONAL SERTAL NUMBER.

Please follow the procedures detailed below in the given sequence:

1. Visit your NTC Student e-mail and look for a message from Northcentral Technical
College - Computer and Information Technology - DreamSpark. Itshould look like the
image below.



An account has been created for you inbox =
Northcentral Technical College - Compui 9:05 PM (0 minutes ago) L
to me [~

** This is an automated message -- please do not reply as you will not receive a
response. **

Welcome grey husband@gmail.com to your DreamSpark WebStore:
MNorthcentral Technical College - Computer and Information Technology - DreamSpark

You'll be excited to know a user account was just created for you at your school's
DreamSpark WebStore. With it, you can download and access a wide range of
Microsoft developer tools, servers, and platforms for freel

Get Started Now
To complete the registration process, you need to follow just 1 stepl Clicking the

registration link below will send you to a page where you'll be asked to create a unigue
password for your account. Once that's complete, you're donel

Complete Your Registration:

If you experience problems clicking the link above, please try copying and pasting the
entire link into a browser.

Technical Support

Note: If you do not receive this e-mail contact your instructor and skip to section 2 - you

can come back to this section after receiving the above mentioned e-mail.

From within this e-mail click on the first e5.onthehub.com link provided. This link will
allow you to complete your registration and login to the MSDN web site. See image below.
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today. Create tomorrow.
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[ | Microsoft DreamSpark
| Software | Mail Order |
Last Name™* First Name®
Husband Grey

Username (email address)™
grey.husband@gmail.com

Email Address™®
grey.husband@gmail.com

11 would like to subscribe to receive information on the latest Microsoft events, updates, special offers, and
more!

Choose a Password™

sessesesee Complete this registration
Password must be at least six characters long. )
Confirm Password* document and then click
(ITIITTIT1T] ]

Register.

Must match the password above.

Back




3. After you click Register you will be logged on to the MSDN web site, which is called
Microsoft DreamSpark. See image below.

Welcome grey.husband@gmail.com Sign Out | English | B

\l
today. Create tomorrow. e

Microsoft DreamSpark:

M Tweet <0 Y Like E Sign Up to see what your friends like.

+ Announcing the new DreamSpark Program 2012-01-16
e New Secure Download Manager 2012-01-13

©® Thank you for registering.
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Operating Systems (20) e
Developer Tools (59)

Microsoft Windows 7 Microsoft Visual Microsoft Visio 2010
Servers (46) Studio 2010
Applications (32) ; o

.—. A
Other (4) h £
Al (157) Microsoft Project Microsoft Expression Microsoft XNA Game
2010 Studio 4 Studio 4

4. Inthe Microsoft Corporation window you will notice the popular downloads, including
Windows 7. Click on the Microsoft Windows 7 icon. If you do not see the Microsoft
Windows 7 option shown in the image above, click on Operating Systems and look for it
there.

5. After clicking the Microsoft Windows 7 icon you will get a list of different downloads for
Microsoft Windows 7 Professional. Click the Add to Cart link next to the 32 bit edition of
Microsoft Windows 7 Professional with Service Pack 1. See image below.



. Microsoft software for learning,
D ream S p d rk - teachiné; and research -

‘ Product Search

DreamSpark Premium Mail Order Special Offers

Microsoft Windows 7 Professional

Microsoft Windows 7 with Service Pack 1 Debug/Checked Build

Microsoft Windows 7 Professional

Download

Microsoft Windows 7 Professional with Service Pack 1 32/64-bit (English] - Free
DreamSpark

Available to: Students/Facuity, Staff Qllﬂl'lﬁl]!: Il

Simplify everyday tasks: find something instantly, compare documents side-by-side, or easily back-up your
complete system aver a network.

Enjoy a PC that works the way you want it to; supports 84-bit technologies and offers XP Mode for your
business productivity applications.

Make new things possible: watch Internet TV, pause, rewind, and record TV or use Touch to interact with
your PC in new ways.

6. After clicking Add to Cart, you will be prompted with the Your Cart window shown below.

Click Check Out.



. Microsoft software for learning,
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| Product Search Q

DreamSpark Premium Mail Order Special Offers

Quantity  Unit Price Price

Microsoft Windows 7 Professional with Service Pack 1 I Free Free
. o . 1 Remove
32/64-bit (English) - DreamSpark - Download -
Cste Aooeo: 2013-01-21 1229 PM

Extended Access Guarantee {24 months) - Included

24 montns of access to your downloaa ana/or key. This does not extend the

duration of time-fimited Fcenses (if applicable).

Update Cart | Subtotal: $0.00

) Continueshopp'lngl ¥  Check Out I

7. Inthe DreamSpark EULA window agree to the terms listed.

8. Inthe Windows 7 Upgrade Considerations window, click Continue.

9. Inthe Order window click Proceed with Order.

10. In the Receipt window you will find the Product Key that you will need to activate your
Windows 7 Professional. Leave this window open for section 2. See image below



Receipt

© Your order has been placed and a confirmation email will e sent to you shortly. You may want to print this page for your
records. Detailed information about all of your orders can be found under Your Account.

Order Summary

Order Date: 2013-01-31 12:31 PM

Central Standard Time

Order Mumber: 100162131005

Order Information

Mame: gregg husband
Email: husband@ntc.edu

Iems All prices are in US Dollars

Microsoft Windows 7 Profe
(English] - DreamSpark - Dg

Expirss 2015-01-31

Extended Access
24 months of access to your d
the duration of time-imited icenses (if apph

Unit Price Amount

Product code shows

Product Key:

Instructions:

Messages:

*  Windows Upgrade Lonsiderat

Agreement Mumber: 12038785859

$0.00 %000
owniosd and;/or E’!p = does not extend
j
Subtotal: $0.00

11. If you are working from a Windows box you can download the Windows 7 Professional
installation image by clicking Start Download. Follow the instructions that you will be
given. After the download is complete, you will have the installation image that you will

need for Section 2. See images below.

» Downloads » Windows 7 Professional with Service Pack 1 (x86) - DVD (English)

b Share with ~ Burn

MNew folder

-

MName

S

H | en_windows_7_professional_with_spl_x86_dvd_u_677056.is0

If you have difficulty downloading the .iso image shown above, please download the
file from the following directory on NTC’s network drive.




g:\cit\husband gregg\class information\misc-isos

Proceed to Section 2.

SECTION 2: INSTALL THE WINDOWS 7 PROFESSIONAL WITHIN VMWARE.

Please follow the procedures detailed below in the given sequence:

1. Hook up your USB hard drive to your USB port on your computer and plug it into the power
supply if necessary. Some USB hard drives do not have a power supply and will get the
power needed from the USB connection. If you have a cable with two USB connectors, one
will be for power (usually the thinner of the two cables) while the other will be used for
data transfer. The USB hard drive should automatically be recognized and given a drive
letter. When this happens, you will see a green arrow in your tool bar on the bottom right.
If you place your cursor over this green arrow it will show you that this is how you properly
dismount the hard drive. If you click on the arrow it will show you the drive letter. If you
click on the drive letter you will dismount the hard drive. See image below.
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2. Startup your VMware Workstation software. If you do not have this software installed,
please read How to install VMware Workstation 8.0. If you are working from a lab
computer, the software should have already been installed. See image below.
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3. Click on Create a New Virtual Machine to build the container that will hold your virtual
operating system. This will only have to be done once per virtual operating system that you
build. For now, you will only be building only one virtual operating system. See image
below.



4,

Li VMware Workstation

File Edit View VM Tabs Help
- B =N

(e [@] =]

——

VMware” Workstation 8

i

[ [6s

Create a New Virtual Machine Virtual Network Editor
Create a virtual machine on this computer. Change the network configuration used by
-~ virtual machines on this computer.
Open a Virtual Machine '_\ = Workstation Preferences
Open a virtual machine on this computer. h 1= Customize VMware Warkstation to your way of
[ working.
Connect to a Remote Server Software Updates
Open virtual machines on a remote server. @ Check for software updates for VMware
SR Workstation.
Virtualize a Physical Machine Help
Create a virtual machine from an existing @ View the help topics for VMware Workstation.

physical machine.

In the Welcome to the New Virtual Machine Wizard window, click Typical and then click

Next. See image below.

New Virtual Machine Wizard | x |

VMware®

Workstation 8

5

Welcome to the New Virtual
Machine Wizard

What type of configuration do you want?

(@) Typical (recommended)

Create a Workstation 8.0 virtual machine
in a few easy steps.

I Custom (advanced)

Create a virtual machine with advanced
options, such as a SCSI controller type,
virtual disk type and compatibility with
older VMware products.

< Back Next = ] [ Cancel




6.

In the Guest Operating System Installation window, click the radio button next to Installer
disc image file (iso). Click the Browse button, locate and select the Windows 7 Professional
image file (.iso) that you had either downloaded from the MSDN web site or that you had
downloaded from NTC'’s G: drive. This .iso should be named with a prefix of
en_windows_7_professional_with_sp1_x86_dvd. If you do not have this file, contact your
instructor immediately. You cannot continue without this file! Once selected, click Next.
See image below.
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MNew Virtual Machine Wizard

Guest Operating System Installation

A virtual machine is like a physical computer; it needs an operating
system. How will you install the guest operating system?

Install from:
() Installer disc:

& DVD RW Drive (D:) -

(@) Installer disc image file (iso):

C:\Users\husband\Downloads\Windows 7 Profession: =

5 Windows /& detected

This operating system will use Easy Install. [What's this?}
(") Twill install the operating system later.

The virtual machine will be created with a blank hard disk.

[ < Back H Next = H Cancel ]

In the Easy Install Information window, enter the product key that you obtained from the
MSDN web site (see Section 1). If you still have the Receipt window open listing the
Windows 7 Professional product key, you may copy and paste it, otherwise simply type it in.
While in the Easy Install Information window change the version to be Windows 7
Professional (this is important!). Enter a user name, such as your last name, and a
password of p@sswOrd (0=zero). Click Next. See image below.



Mew Virtual Machine Wizard

Easy Install Informatio

This is used to install W Enter PdeUCt KE}{

here.

Windows product key

Version of Windows to install

[Winduws 7 Professional -

Personalize Windows

Full name: husband
Password: (TIIII11] {optional)
Confirm: Tl

[|Log on automatically (requires a password)

[ < Back ][ Mext = ][ Cancel ]

Note: if you do not have the product key at this time, you can still continue, you will just
have to enter it manually when you activate the operating system. Your operating system
will still function normally without activation for up to 30 days. Also, be sure that you
select Windows 7 Professional as the version of Windows to install!

In the Name Virtual Machine window, either keep the default virtual machine name or
change it to your liking. Change the Location to be where you would like to store the virtual
machine files using the following guidelines:

e The drive letter should be the drive letter that represents your USB hard drive (see
step 1).

e The directory structure where the virtual machine files will be stored should have a
parent directory called “Virtual Machines” or “VMs” and have a subdirectory named
after the virtual machine’s name. You may wish to include multiple subdirectory
names to identify the semester and the class. See the example shown below.
WARNING: DO NOT TAKE THE DEFAULT LOCATION.



MNew Virtual Machine Wizard | 52 |

Name the Virtual Machine
What name would you like to use for this virtual machine?

Virtual machine name:

Windows 7 Professional - POIS

Location:

E:\WWMs\Windows 7 Professional - POIS Browse...

The default location can be changed at Edit > Preferences.

< Back H Next = H Cancel

8. Click Next.
9. In the Specify Disk Capacity window, change the default of 60 GB Maximum disk size to 30

GB and take the default method of storing the virtual disk file. Click Next.

10. In the Ready to Create Virtual Machine window, review your settings and then click Finish.
After you click Finish, the install process will start and continue automatically.

11. After the installation is complete, your virtual Windows 7 Professional computer will restart
and then prompt you to login as your user name. See image below.
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12. To login you must first click inside the Windows 7 Professional virtual PC window, enter the
password that you had established earlier (p@sswOrd) and then click the blue arrow. You
should successfully get logged in and your screen will look like the image below.

Note: If during the login process you will likely be prompted to define a network
type, select Work. Also, you will notice that VMware tools will automatically get
installed, this is OK.
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13. Now activate you're your operating system by performing the following steps:
a. Click Start -> Help and Support.
b. Type Activate in the search help box and press <Enter>
c. Click Activate Windows on this computer. See image below.
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@ - m i!fj il _ﬁ%ﬁ.sk Options -

| activate L2 |

»

@ We update Help frequently. To see our latest content, switch to online help.
Read the privacy staternent on the Microsoft website.

Best 30 results for activate

1. Activating Windows: frequently asked gquestions

I 2. Activate Windows on this cu:umputerl

m

d. Read the information about activation and then click Click to open Windows
activation. See image below.

' @Windmvs Help and Support Ii“ﬂl[é]
@ 3/ m 13!5;: i] 9% Ask Options =

| activate » |

Activate Windows on this computer

You must activate Windows within 30 days of installation.

Activation helps verify that Windows on your computer is genuine and that it has not
been used on more computers than the Microsoft Software License Terms allow. In
this way, activation helps prevent software counterfeiting.

You can activate either cnline or by phone. To activate onling, you'll need an Internet

connection. Activating by phone requires interacting with an automated phone
system.

+ - Click to open Windows activation. ®/ If you are prompted for an

administrator password or confirmation, type the password or provide
confirmation.

You can then select the method you want to use to activate,
Note

& If you chose to automatically activate Windows online when you set up your

computer, automatic activation begins trying to activate Windows three days
after you log on for the first time.

e. Ifprompted, click Activate Windows online now. See image below.



N % Windows Activation

Activate Windows now

You must activate Windows within 30 days to continue using all Windows features.

® Activate Windows online now

& Ask me later

What is activation?
Bead the privacy statement online

Cancel

f. Ifyou did not enter a product key when the installation of Windows 7 Professional
was first initiated, you will be prompted for one now. If so, copy and paste (or
manually enter) the product key in the appropriate box. Your product key will be
verified and if the product key is valid, your operating system will become activated.

g. Close the Windows Activation window shown in the image below.



N ‘% Windows Activation

Activation was successful

Activation helps verify that your copy of Windows is genuine, With
a genuine copy of Windows 7, you are eligible to receive all
available updates and product support from Microsoft.

Learn more online about the benefits of genuine Windows

Close

14. At this point you can shut down your virtual PC. Click Start -> Shutdown.
15. Continue to Section 3.

SECTION 3: STARTING AN EXISTING WINDOWS 7 PROFESSIONAL VIRTUAL
COMPUTER.

You will continually have to reconnect to the virtual PC that you just created. To do so follow these
procedures:

1. Startyour VMware Workstation software.

2. When you start your VMware workstation software you may not see a tab showing your
Windows 7 Professional virtual operating system. You will have to click Open a Virtual
Machine. See image below.



i=t Home 1 [ Windows 7 Professional - POIS 1

VMware” Workstation 8

Create a New Virtual Machine
Create a virtual machine on this computer.

Virtual Network Editor

Change the network configuration used by
virtual machines on this computer.

Open a Virtual Machine
Open a virtual machine on this computer.

Workstation Preferences

Customize VMware Workstation to your way of
working.

Connect to a Remote Server Software Updates
Open virtual machines on a remote server. |©' Check for software updates for VMware
SR Workstation.
Virtualize a Physical Machine Help
lI .= Create a virtual machine from an existing |9| View the help topics for VMware Workstation.
= ! physical machine. 4

3. When prompted to locate the virtual operating system’s configuration file on your USB hard
drive, select the Windows 7 Professional.vinx located in the Virtual Machines\Windows 7
Professional folder where you created your virtual machine. You should then get a
Windows 7 Professional tab shown in the image below.




il Windows 7 Professional - POIS - VMware Workstation (= | I I S

File Edit View VM Tabs Help
P - (O} (CTINI ==X

Home [ Windows 7 Professional - POIS

[ Windows 7 Professional - POIS

P Power on this virtual machine
G Edit virtual machine settings

¥ Devices
% Memory 1GB
[ Processors 1

= Hard Disk (SCSI) 60 GB

- CD/DVD (IDE) Auto detect
= Floppy Auto detect
¥& Network Adapter NAT
& UsB Controller Present

@) Sound Card Auto detect
i=1 Printer Present
& Display Auto detect

~ Description
Type here to enter a description of this
virtual machine.

Virtual machine's configuration file. I

> Virtual Machine Details
State: Powered off
Configuration file: E\VMs\Windows 7 Professional - POIS\Windows 7 Prafessional - POIS.vmx
Hardware compatibility: Workstation 8.0 virtual machine

4. While your virtual machine is SHUTDOWN and POWERED OFF, improve the performance

of your virtual machine by modifying the virtual machine’s configuration as follows:
a. Select Edit virtual machine settings (the link below the power on link in the upper
left hand corner).
Select the Floppy device and then select Remove.
Select the Sound Card device and then select Remove.
Click OK.
Open your Windows Explorer and then locate the .vimx file shown in your VMware
startup page. See image below.
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@O" |, « FreeAgent GoFlex Drive (E) » VMs » Windows 7 Professional - POIS » - | + | | Search Windows 7 Profession.. R |
Organize v «] Open ~ Burn New folder =~ O @
| isofiles Name : Date modified Type i
: zi:?;:?des | caches 8/27/2012 1.50 PM File folder il
L VMs | Windows 7 Professional - POIS.vmcIck 8/27/2012 1:31 PM File folder
| Clones vmware.log 8/27/2012 1:59 PM Text Document
| 1P Cop - NAT 202 vprintproxy.log 8/27/2012 1:59 PM  Text Document
T D Windows 7 Professional - POIS.nvram 8/27/2012 1:.59 PM VMware virtual ma...
E Windows 7 Professional - POIS.vmdk 8/27/2012 1:50 PM VMware virtual dis...
: ::Ei::tz?;oc i D Windows 7 Professional - POIS.vmsd 8/27/2012 1:31 PM VMware snapshot ...
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f.  Right-click this file and then select Open with -> Notepad.

g. Scroll to the bottom of that file and then copy and paste the following code to the

bottom:

prefvmx.minVmMemPct = "100"
mainMem.useNamedFile = "FALSE"
mainMem.partialLazySave = "FALSE"
mainMem.partialLazyRestore = "FALSE"

Your modified configuration file should look like the image below.



jWindows?Professional—POIS.vmx—Notepad o= | =]
File Edit Format View Help

cleanshutdown = "TRUE" -
replay.supported "FALSE"

unity.wasCapable "FALSE"

replay.filename = ""
scsi0:0.redo = ""

pciBridge0.pcislotNumber = "17"
pciBridge4.pcislotNumber = "21"
pciBridges.pciSlotNumber = "22"
pciBridge6.pcislotNumber = "23"

pciBridge7.pcislotNumber = "24"
scsi0.pciSlotNumber = "160"

ush.pcisTotNumber = "32"
ethernet0.pcislotNumber = "33"
ehci.pcisTotNumber = "35"

vmci0.pcislotNumber = "36"

scsi0.saswwID = "50 05 05 6¢c db 55 18 10"
ush:0.present "TRUE"

ush:1.present "TRUE"

ethernet0. generatedaddressoffset = "0"
tools.remindInstall = "FALSE"

vmotion. checkpointFBSize = "134217728"
usb:0.deviceType = "hid"

ush:0.port = "0"

usbh:0.parent = "-1"
usb:1.speed = "2"
ush:1.deviceType = "hub"
usb:1l.port = "1"
ush:1.parent = "-1"

11

idel:0.autodetect = "TRUE"
sound.present = "FALSE"

— "FA] SF"
. m ct = "100
.useNamedFile = "FALSE"
ainMem.partiallLazySave = "FALSE"
ainMem.partialLazyRestore = "FALSE"

4 P

h. While in Notepad, click File -> Save and then click File -> Exit.

5. To start your virtual machine click the Power on this virtual machine option listed in the
Commands section in the upper left hand corner. Your virtual machine will then boot up,
thus enabling you to login.

6. After you are done using the virtual PC, always shut down the virtual machine from the
virtual machine’s operating system as instructed in section 2, step 14. DO NOT JUST CLOSE
VMWARE!
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